Задать вопрос
12 октября, 19:49

Компьютер выводит среднее арифмитическое число не оканчивающееся на 5 и на 8.

Помогите решить!

+1
Ответы (1)
  1. 12 октября, 20:49
    0
    Var

    s, n, k:integer;

    begin

    Writeln ('введите натуральные числа, 0 - окончание ввода') ;

    k:=0; s:=0;

    repeat

    Read (n) ;

    if n0 then

    if n mod 10 = 8 then begin k:=k+1; s:=s+n end

    until n=0;

    if k>0 then Writeln (s/k:0:4)

    else Writeln (0)

    end.

    Пример

    введите натуральные числа, 0 - окончание ввода

    34 17 8 32 1424 28 7 0

    18.0000
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Компьютер выводит среднее арифмитическое число не оканчивающееся на 5 и на 8. Помогите решить! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте задачу на Паскаль, используя диалог с пользователем. Компьютер выводит на экран: -Здравствуй, я компьютер, а тебя как зовут? Человек вводит с клавиатуры: -Коля Компьютер выводит на экран: -Очень приятно, Коля.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Какие пары объектов НЕ находятся в соотношении "объект-модель"? а) компьютер и его фотография б) компьютер и его функциональная схема в) компьютер и его процессор г) компьютер и его техническое описание
Ответы (1)
Напишите программу на Паскаль, которая в последовательности натуральных чисел определяет максимальное отрицательное число, оканчивающееся на 3. Программа получает на вход количество чисел в последовательности, а затем сами числа.
Ответы (1)
Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами.
Ответы (1)