Задать вопрос
5 мая, 22:50

Составьте программу, по которой вычисляется f=10! (Факториалом числа N называется произведение всех натуральных чисел от I до N включительно).

+4
Ответы (1)
  1. 6 мая, 02:40
    0
    Var n, f, i:integer;

    begin

    n:=10;

    f:=1;

    for i:=1 to n do f:=f*i;

    writeln (n,'! = ', f) ;

    end.

    Результат:

    10! = 3628800
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, по которой вычисляется f=10! (Факториалом числа N называется произведение всех натуральных чисел от I до N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N! = 1·2·3 ... (N - 1) · N.
Ответы (1)
Задание: сделать функцию определения того, что данное число является факториалом: function reversef (f: integer; var n: integer) : boolean (возвращает true, если f - факториал, n - число, факториалом которого является f.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
Даны два целых числа А и В (А < В). Найти произведение всех целых чисел от А до В включительно. Входные данные: ввести два целых числа А, В (1
Ответы (1)