Задать вопрос
3 апреля, 12:57

Описать функцию RootsCount (A, B, C) целого типа, определяющую количество корней квадратного уравнения A∙x2 + B∙x + C = 0 (A, B, C - вещественные параметры, A ≠ 0). С ее помощью найти количество корней для каждого из трех квадратных уравнений с данными коэффициентами. Количество корней определять по значению дискриминанта: D = B2 - 4∙A∙С.

+3
Ответы (1)
  1. 3 апреля, 16:06
    0
    Function RootsCount (a, b, c:real) : integer;

    var d:real;

    begin

    d:=b*b-4*a*c;

    if d>0 then RootsCount:=2

    else if d=0 then RootsCount:=1

    else RootsCount:=0;

    end;

    var a, b, c:real; i:integer;

    begin

    for i:=1 to 3 do

    begin

    writeln (i,') a, b, c:') ;

    readln (a, b, c) ;

    writeln ('Количество корней = ', RootsCount (a, b, c)) ;

    end;

    end.

    Пример:

    1) a, b, c:

    1 2 3

    Количество корней = 0

    2) a, b, c:

    -4 5 6

    Количество корней = 2

    3) a, b, c:

    -2 8 - 8

    Количество корней = 1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Описать функцию RootsCount (A, B, C) целого типа, определяющую количество корней квадратного уравнения A∙x2 + B∙x + C = 0 (A, B, C - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны вещественные числа a, b, c (не равны 0). Выяснить, имеет ли уравнение с такими коэффициентами вещественные корни.
Ответы (1)
Как установить левое поле страницы в 2,5 см? (MS Excel) Файл - Параметры страницы ... - Поля - левое - 2,5 - Сохранить Файл - Параметры страницы ... - Поля - Сохранить Файл - Параметры страницы ...
Ответы (1)
1) даны 3 числа a, b, c, являющиеся коэффициентами квадратного уравнения. Составить алгоритм и программу для нахождения корней этого квадратного уравнения.
Ответы (1)
Описать процедуру SortInc3 (A, B, C), меняющую содержимое переменных A, B, C таким образом, чтобы их значения оказались упорядоченными по возрастанию (A, B, C - вещественные параметры, являющиеся одновременно входными и выходными).
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)