Задать вопрос
6 марта, 08:07

В файле input. txt находится произвольное количество чисел, записанных в каждой новой строке. Требуется найти сумму всех чисел и записать ее в файл output. txt

+5
Ответы (1)
  1. 6 марта, 11:45
    0
    Var

    f:text;

    A, S:real;

    Begin

    S:=0;

    Assign (f,'input. txt') ;

    Reset (f) ;

    While not EOF (f) do

    Begin

    Read (f, A) ;

    S:=S+A;

    End;

    Close (f) ;

    Assign (f,'output. txt') ;

    Rewrite (f) ;

    Write (f, S) ;

    Close (f) ;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В файле input. txt находится произвольное количество чисел, записанных в каждой новой строке. Требуется найти сумму всех чисел и записать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Файл input. txt: Мама, короче, мыла, короче, раму. Декан, короче, пропил, короче, бутан. А роза, короче, упала на лапу, короче, Азора. Каждый, короче, охотник желает, короче, знать, где короче сидит фазан В файле input.
Ответы (1)
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)