Задать вопрос
14 ноября, 07:11

Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале

+3
Ответы (1)
  1. 14 ноября, 10:11
    0
    Var

    A, c, n:integer;

    Begin

    WriteLn ('Введите натурально число') ;

    Read (A) ;

    c:=0;

    n:=0;

    While A>0 do

    Begin

    if (A mod 10) mod 2 = 0 then c:=c+1;

    if (A mod 10) mod 2 0 then n:=n+1;

    A:=A div 10;

    End;

    WriteLn ('Кол-во чётных цифр: ', c) ;

    WriteLn ('Кол-во нечётных цифр: ', n) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число найдите количество четных и нечетных цифр в нем. написать программу на паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Дано натуральное число. Определить: б) сколько раз в нем встречается цифра, равная последней; в) количество четных цифр в нем.
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)