Задать вопрос
9 августа, 17:20

Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N

+1
Ответы (1)
  1. 9 августа, 17:29
    0
    Var n, i:integer;

    begin

    write ('n = ') ;

    readln (n) ;

    i:=1;

    while i*i<=n do

    begin

    write (i,' ') ;

    i:=i+1;

    end;

    writeln;

    end.

    Пример:

    n = 30

    1 2 3 4 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N, составить программу, котоая выводит на экран все натуральные числа, квадрат которых не больше чем N ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)
дано целое число. напишите программу которая выводит на экран последнюю цифру данного числа затем возводит её в квадрат и выводит на экран монитора результат
Ответы (1)
Программа на с++ Напишите программу, которая вводит натуральные числа а и b и выводит на экран все натуральные числа на отрезке [ a, b ], делящиеся на каждую из своих цифр.
Ответы (1)