Задать вопрос
14 апреля, 13:20

Дан целочисленный линейный массив. Отсортировать его элементы в порядке возрастания значений.

+4
Ответы (1)
  1. 14 апреля, 15:54
    0
    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, j, Min, B:integer;

    Begin

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (2*n+1) - n;

    Write (' ', A[i])

    End;

    WriteLn;

    Write ('После сортировки:') ;

    For i: = 1 to N do

    Begin

    Min:=i;

    For j:=i+1 to N do

    if A[j] < A[Min] then Min:=j;

    B:=A[Min];

    A[Min]:=A[i];

    A[i]:=B;

    Write (' ', A[i])

    End;

    ReadLn;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан целочисленный линейный массив. Отсортировать его элементы в порядке возрастания значений. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Паскаль! Дан целочисленный массив. Отсортировать массив по убыванию, начиная с максимального элемента
Ответы (1)