Задать вопрос
5 декабря, 19:42

Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел, уже записанных в готовом текстовом файле, и выводит результат в другой файл.

+1
Ответы (1)
  1. 5 декабря, 20:11
    0
    Program n1;

    var a, max: integer;

    f: text;

    begin

    assign (f,'input. txt') ;

    reset (f) ;

    max:=0;

    while not eof (f) do

    begin

    read (f, a) ;

    if (abs (a) >max) and (a<0) and (a mod 2 0) then max:=a;

    end;

    close (f) ;

    assign (f,'output. txt') ;

    rewrite (f) ;

    write (f, max) ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу в Паскале, которая находит максимальное нечетное отрицательное число среди чисел, уже записанных в готовом текстовом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая находит максимальное нечетное число среди чисел, записанных в файле, и выводит результат в другой файл. подскажите как найти это число хотя бы
Ответы (1)
Напишите программу, которая находит минимальное и максимальное среди чётных положительных чисел, записанных в файле, и выводит результат в другой файл. Учтите, что таких чисел может вообще не быть. (Язык программирования Паскаль)
Ответы (1)
Напишите программу, которая находит максимальное всех арифметических чисел, записанных в файле в столбик, и выводит результат в другой файл
Ответы (1)
Напишите программу, которая находит среднее арифметическое всех чисел, записанных в файле в столбик, и выводит результат в другой файл.
Ответы (1)
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)