Задать вопрос
26 августа, 23:42

Напише программу для вычисления n!=1*2*3 * ... * n-1*n; n<=10 c помощию цикла while

+2
Ответы (2)
  1. 27 августа, 01:44
    0
    Program ABC;

    var i, N, S:integer;

    Begin

    Read (N) ;

    S:=1;

    For i:=1 to N do

    Begin

    S:=S*i;

    End;

    Writeln (S) ;

    End.

    Подставляешь n - это будет твое число под факториалом.

    Программа выводит ответ.
  2. 27 августа, 01:49
    0
    var n, f, i:integer;

    Begin

    write ('n = ') ;

    readln (n) ;

    f:=1; i:=1;

    while i
    begin

    i:=i+1;

    f:=f*i;

    end;

    Writeln (n,'! = ', f) ;

    End.

    Пример:

    n = 5

    5! = 120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напише программу для вычисления n!=1*2*3 * ... * n-1*n; n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х
Ответы (1)
1. Cоставить программу вычисления площади круга: S = п (пи) * R^2 2. Cоставить программу вычисления площади треугольника: S=1/2*A*H 1) Выделить целую часть результата.
Ответы (1)