Задать вопрос
13 апреля, 02:05

Найдите произведение положительных элементов в массиве

+2
Ответы (1)
  1. 13 апреля, 04:06
    0
    Var

    A:array[1 ... 33] of integer;

    i:integer;

    P:real;

    Begin

    Write ('Массив: ') ;

    P:=1;

    For i: = 1 to 33 do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    if A[i]>0 then P:=P*A[i];

    End;

    WriteLn;

    Write (P)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите произведение положительных элементов в массиве ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
В заданном массиве А (m, n) найти количество положительных элементов по столбцам. Образовать массив B (m, n), делением элементов заданного массива на найденное количество положительных элементов по столбцам.
Ответы (1)
1. Напишите алгоритм подсчета числа элементов, равных максимальному, в числовом массиве из 30 элементов. 2. Напишите алгоритм поиска трех последовательных элементов, сумма которых максимальна, в числовом массиве из 30 элементов.
Ответы (1)