Задать вопрос
2 октября, 05:41

Помогите нужен прог. паскаль!

Дан одномерный массив A[n].

Найти среднее значение массива и подсчитать количество элементов, значения которых равны квадратному корню из среднего.

+2
Ответы (1)
  1. 2 октября, 08:16
    0
    Const

    N = 30;

    Var

    A:array[1 ... N] of integer;

    i:integer;

    C, K, Q:real;

    Begin

    For i: = 1 to N do

    Begin

    A[i]:=random (21) ;

    Write (A[i],' ') ;

    C:=C+A[i];

    End;

    WriteLn ('Среднее арифметическое элементов массива равно: ', C) ;

    C:=sqrt (C) ;

    K:=0;

    For i: = 1 to N do

    if A[i]=C then K:=K+1;

    WriteLn ('Кол-во элементов, равных ', C,' равно ', K) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите нужен прог. паскаль! Дан одномерный массив A[n]. Найти среднее значение массива и подсчитать количество элементов, значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)