Задать вопрос
27 мая, 15:37

В двумерном массиве А (4,4) определить сумму элементов меньших 7

+5
Ответы (1)
  1. 27 мая, 19:23
    0
    Const

    N = 4;

    C = 7;

    Var

    A:array[1 ... N, 1 ... N] of integer;

    i, j:integer;

    S:real;

    Begin

    Randomize;

    WriteLn ('Исходный массив:') ;

    S:=0;

    For i: = 1 to n do

    Begin

    For j: = 1 to N do

    Begin

    A[i, j]:=random (21) - 10;

    Write (A[i, j]:3,' ') ;

    if A[i, j] < C then S:=S+A[i, j];

    End;

    WriteLn

    End;

    WriteLn ('S = ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве А (4,4) определить сумму элементов меньших 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Задачи на массивы (в паскале) : 1. Найти количество нулей в одномерном массиве. 2. найти сумму элементов кратных 5. 3. найти сумму первых 5 элементов. 4. верно ли что в массиве есть два нуля. 5. найти сумму элементов из промежутка от А до В.
Ответы (1)
В двумерном массиве 4 х3 найти количество элементов, больших - 5. Если таких элементов не оказалось - вывести сообщене "Таких элементов нет!". Элементы ввести с клавиатуры.
Ответы (1)