Задать вопрос
26 июня, 22:40

Даны три числа D. C. F. Найти количество чисел больших нуля

+2
Ответы (2)
  1. 26 июня, 23:50
    0
    Program z2; Var d, c, f, s:integer; Begin

    Write ('D = ') ; readln (d) ; Write ('C = ') ; readln (c) ; Write ('F = ') ; readln (f) ; s:=0; if (d > 0) then s: = s + 1; if (c > 0) then s: = s + 1; if (f >0) then s: = s + 1;

    writeln ('Кол-во чисел болььших 0 = ', s) End.
  2. 27 июня, 00:13
    0
    Uses crt;

    var a, b, c, s, k : integer;

    begin

    writeln ('Введите 3 числа : ') ;

    readln (a, b, c) ;

    if a > 0 then

    begin

    k: = k + 1;

    s: = a;

    end;

    if b > 0 then

    begin

    k: = k + 1;

    s: = s + b;

    end;

    if c > 0 then

    begin

    k: = k + 1;

    s: = s + c;

    end;

    writeln ('Сумма чисел = ', s) ;

    writeln ('Количество положительных чисел = ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны три числа D. C. F. Найти количество чисел больших нуля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)
Составить программы на языке Турбо Паскаль. 1. Даны N чисел. Найти произведение четных и сумму нечетных. 2. Даны N чисел. Найти количество положительных и количество отричательных. Сравнить результаты.
Ответы (1)
Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000.
Ответы (1)