Задать вопрос
28 марта, 01:26

Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и заканчивающихся на 7 (программа Pascal)

+4
Ответы (1)
  1. 28 марта, 04:05
    0
    Var a:array[1 ... 5] of integer;

    i, s:integer;

    begin

    writeln ('Введите 5 чисел:') ;

    for i:=1 to 5 do

    begin

    read (a[i]) ;

    if (a[i] mod 3 = 0) and (a[i] mod 10 = 7) then s:=s+a[i];

    end;

    writeln ('s = ', s) ;

    end.

    Пример:

    Введите 5 чисел:

    125 273 117 471 207

    s = 324
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Массив из пяти элементов заполняется натуральными числами. Составить программу, которая определяет сумму элементов массива, кратных трем и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)