Задать вопрос
14 января, 16:20

Дано целое двузначное положительное число n. Составьте программу, которая определяет, входят ли в него цифры 2 и 5

+4
Ответы (1)
  1. 14 января, 17:24
    0
    Var a, a1, a2:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    a1:=a div 10;

    a2:=a mod 10;

    if (a1=2) or (a2=2)

    then writeln ('В числе есть цифра 2') ;

    if (a1=5) or (a2=5)

    then writeln ('В числе есть цифра 5') ;

    if (a12) and (a22) and (a15) and (a25)

    then writeln ('В числе нет цифр 2 и 5') ;

    end.

    Пример:

    a = 25

    В числе есть цифра 2

    В числе есть цифра 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое двузначное положительное число n. Составьте программу, которая определяет, входят ли в него цифры 2 и 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1). Дано целое число Х. Составьте программу которая выясняет верно ли что 0 больше или равно Х и больше 1. 2). Дано целое число П. Составьте программу которая выясняет является им значение П кратное 3.
Ответы (1)
Дано целое двухзначное положительное число n. Составьте программу, которая определяет, входит ли в него цифра 4. (Скорее всего по Поскалю надо решать)
Ответы (1)