Задать вопрос
13 июня, 16:25

Дано четырехзначное числою определить сумму первой и последней цифры и 2 и 3 помогите написать программу по паскалю

+4
Ответы (2)
  1. 13 июня, 16:35
    0
    Var

    A:integer;

    Begin

    WriteLn ('Введите четырёхзначное число') ;

    ReadLn (A) ;

    WriteLn ('Сумма цифр:') ;

    WriteLn ('Первой и последней = ', A div 1000 + A mod 10) ;

    WriteLn ('Второй и третьей = ', (A div 100) mod 10 + (A div 10) mod 10) ;

    End.
  2. 13 июня, 19:20
    0
    Uses crt;

    var s: String;

    i1, i2, err: Integer;

    r: Integer;

    begin

    readln (s) ;

    clrscr;

    val (s[1], i1, err) ;

    val (s[Length (s) ], i2, err) ;

    r : = i1 + i2;

    writeln (r) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырехзначное числою определить сумму первой и последней цифры и 2 и 3 помогите написать программу по паскалю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу проверяющая является ли данное целое число четырехзначным числом. На экране должно быть сообщение число четырехзначное или число не четырехзначное. По паскалю.
Ответы (1)
47. дано целое четырехзначное положительное число n. составьте программу, которая определяет, какая из его цифр больше-вторая или последняя 48 дано целое четырехзначное положительное число n.
Ответы (1)
Дано целое положительное четырехзначное число. Напишите программу, позволяющую определить двузначное число, в котором число десятков соответствует первой цифре заданного числа, а число единиц-последней. Например: 3234 = > 34.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)