Задать вопрос
19 сентября, 11:08

1. Найдите произведение чисел в диапазоне от с до d которые делятся на 4;

2. Дано число (трехзначное) найти сумму и определить четная она или нет.

+3
Ответы (1)
  1. 19 сентября, 14:08
    0
    1)

    Program n1;

    var c, d, i: integer;

    p: real;

    begin

    readln (c, d) ;

    p:=1;

    for i:=c to d do if i mod 4=0 then p:=p*i;

    writeln (p) ;

    end.

    2)

    Program n1;

    var a, sum: integer;

    begin

    sum:=0;

    readln (a) ;

    sum: = (a mod 10) + (a div 100) + (a mod 100 div 10) ;

    if sum mod 2=0 then write ('четная')

    else write ('нечетная') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Найдите произведение чисел в диапазоне от с до d которые делятся на 4; 2. Дано число (трехзначное) найти сумму и определить четная она ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Из ряда натуральных чисел от 1 до 2000 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)
Из ряда натуральных чисел от 1 до 1500 вычеркнули все числа, которые делятся на 2, затем все числа, которые делятся на 3, затем все числа, которые делятся на 5, а затем все числа, которые делятся на 7. Сколько чисел осталось?
Ответы (1)