Задать вопрос
21 марта, 16:43

Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа

+1
Ответы (1)
  1. 21 марта, 20:15
    0
    Var a, b, x, s:integer;

    begin

    write ('a = ') ;

    readln (a) ;

    write ('x = ') ;

    readln (x) ;

    b:=a;

    s:=0;

    while b>0 do

    begin

    s:=s+b mod 10;

    b:=b div 10;

    end;

    writeln ('s = ', s) ;

    if s>x

    then writeln ('Сумма цифр больше ', x)

    else writeln ('Сумма цифр не больше ', x) ;

    end.

    Пример:

    a = 31854

    x = 15

    s = 21

    Сумма цифр больше 15
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, определяющую (отвечающею на вопрос) - больше ли числа х сумма цифр введённого числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, которая определяет, является ли сумма цифр введенного целого трехзначного числа четным числом. 2. Составьте программу, которая определяет, является ли последняя цифра введенного целого числа нечетным числом. 8 класс.
Ответы (1)
Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли произвольное число X четным. 2. Написать программу, определяющую, является ли целое число T делителем целого числа X. 3.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Pascal. Требуется помощь. Составьте программу вычисления суммы цифр введённого с клавиатуры трёхзначного натурального числа. Например, для числа 128 сумма цифр 11, для числа 345 сумма цифр 12.
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)