Задать вопрос
26 марта, 03:37

Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0

Используя цикл repeat

+5
Ответы (1)
  1. 26 марта, 06:03
    0
    Var

    A, S, P:real;

    k:integer;

    Begin

    S:=0;

    P:=1;

    k:=-1;

    Repeat

    Read (A) ;

    if A 0 then P:=P*A;

    S:=S+A;

    k:=k+1;

    Until A = 0;

    WriteLn ('P = ', P) ;

    WriteLn ('Sr = ', S/k) ;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу для вычисления произведения целых чисел, их среднее арифметическое до тех пор пока не будет введён 0 Используя цикл ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Осуществить ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён 0) и подсчитать их сумму и среднее арифметическое введённых положительных чисел. Использовать оператор repeat.
Ответы (1)
Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор, пока не будет введён ноль) и определение максимального (наибольшего) из введёных чисел. Используйте оператор repeat. Решить в паскале.
Ответы (1)
Составить две программы на языке Паскаля с помощью операторов цикла До и Пока, которые будут вводить целые числа (до тех пор, пока не будет введен ноль), подсчитывать сумму и среднее арифметическое введеных положительных чисел.
Ответы (1)
Составить программу, которая запорашивает пароль до тех пор пока он не будет правильно введен, вывести количество неправильных попыток (все это с циклом repeat)
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)