Задать вопрос
9 июля, 01:56

Наурыз коже - традиционное блюдо на празднике Наурыз. Рецепты его приготовления разнятся, но за основу берутся 7 обязательных компонентов.

Зная по рецепту количество каждого компонента на порцию и количество имеющих продуктов, определить максимальное количество гостей, которых можно угостить традиционным блюдом праздника Наурыз.

Формат входных данных. В первой строке вводятся 7 натуральных чисел - количество каждого компонента на порцию. Во второй строке вводятся 7 натуральных чисел - количество имеющихся продуктов. Все числа не превосходят 10^9

+5
Ответы (1)
  1. 9 июля, 04:56
    0
    Const n=7;

    var r, p:array[1 ... n] of integer;

    i, max:integer;

    begin

    for i:=1 to n do read (r[i]) ;

    readln;

    for i:=1 to n do read (p[i]) ;

    readln;

    max:=p[1] div r[1];

    for i:=2 to n do

    if p[i] div r[i] < max then max:=p[i] div r[i];

    writeln ('Максимальное количество гостей = ', max) ;

    end.

    Пример:

    120 100 75 80 50 60 40

    2000 1500 1000 500 500 400 400

    Максимальное количество гостей = 6
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Наурыз коже - традиционное блюдо на празднике Наурыз. Рецепты его приготовления разнятся, но за основу берутся 7 обязательных компонентов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N. Формат входных данных Задано единственное число N. Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)
Дан массив из n элементов. Необходимо определить, есть ли в данном массиве элемент, равный заданному числу k ? Если есть, то вывести номер первого его вхождения. Формат входных данных С клавиатуры вводится натуральное число n (n≤100).
Ответы (1)
H. Работа с несколькими массивами Дан массив a, состоящий из n целых чисел. Ваша задача - переписать его элементы в другой массив такого же размера следующим образом: сначала должны идти все отрицательные элементы, а затем все остальные.
Ответы (1)
Дан массив из N целых чисел a1, a2 ..., aN. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равно нулю. Формат входных данных В певой строке входного файла содержится одно целое число n (1
Ответы (1)