Задать вопрос
5 августа, 19:05

В массиве заменить все нулевые элементы суммой всех элементов (паскаль)

+3
Ответы (1)
  1. 5 августа, 19:12
    0
    Program n1;

    const n=10;

    var a: array[1 ... n] of integer;

    i, sum: integer;

    begin

    randomize;

    sum:=0;

    write ('исходный массив: ') ;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i],' ') ;

    sum:=sum+a[i];

    end;

    writeln;

    write ('полученный массив: ') ;

    for i:=1 to n do

    begin

    if a[i]=0 then a[i]:=sum;

    write (a[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве заменить все нулевые элементы суммой всех элементов (паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)