Задать вопрос
1 февраля, 10:23

Дан двухмерный массив 10 на 10. Найти сумму всех элементов. Кол во элементов коатных 5

+3
Ответы (1)
  1. 1 февраля, 11:49
    0
    Program z;

    var

    p, s, n, m:integer;

    a:array [1 ... 10,1 ... 10] of integer;

    begin

    writeln ('Введите кол-во столбцов') ;

    readln (n) ;

    writeln ('Введите кол-во строк') ;

    readln (m) ;

    writeln ('Ввод матрицы') ;

    for var i:=1 to n do

    for var j:=1 to m do

    begin

    write ('a[', i,',', j,']=') ;

    readln (a[i, j]) ;

    end;

    writeln ('Вывод матрицы') ;

    for var i:=1 to n do

    begin

    for var j:=1 to m do

    write (a[i, j],' ') ;

    writeln;

    end;

    s:=0;

    for var i:=1 to n do

    for var j:=1 to m do

    begin

    s:=s+a[i, j];

    end;

    p:=0;

    for var i:=1 to n do

    for var j:=1 to m do

    if a[i, j] mod 5 = 0 then

    begin

    inc (p) ;

    end;

    writeln ('Сумма элементов - ', s) ;

    writeln ('Кол-во элементов, кpатных 5 - ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан двухмерный массив 10 на 10. Найти сумму всех элементов. Кол во элементов коатных 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан двухмерный массив A (n, m). Найти произведение отрицательных четных элементов второго столбца массива. 2. Дан двухмерный массив m*n. Получите одномерный массив b, элементы которого равны min элементам по строкам.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)