Задать вопрос
30 мая, 00:18

Написать программу удаления половины символов, зная, что количество символов в строке - чётное. (Паскаль)

+3
Ответы (1)
  1. 30 мая, 00:25
    0
    Для удаления правой половины символов:

    Var

    S:string;

    Begin

    Write ('Введите строку: ') ; ReadLn (S) ;

    S:=Copy (S, 1, Length (S) div 2) ;

    WriteLn (S) ;

    End.

    Пример работы программы:

    Введите строку: 1234

    12

    Для удаления левой половины символов:

    Var

    S:string;

    Begin

    Write ('Введите строку: ') ; ReadLn (S) ;

    S:=Copy (S, Length (S) div 2+1, Length (S)) ;

    WriteLn (S) ;

    End.

    Пример работы программы:

    Введите строку: 1234

    34

    Удаление выбранной половины символов:

    Var

    S:string;

    A:byte;

    Begin

    Write ('Введите строку: ') ; ReadLn (S) ;

    WriteLn ('1 - удаление правой половины, 2 - удаление левой половины') ;

    ReadLn (A) ;

    if A = 1 then S:=Copy (S, Length (S) div 2+1, Length (S))

    else S:=Copy (S, 1, Length (S) div 2) ;

    WriteLn (S) ;

    End.

    Пример работы программы:

    Введите строку: 1234567890

    1 - удаление правой половины, 2 - удаление левой половины

    2

    12345
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу удаления половины символов, зная, что количество символов в строке - чётное. (Паскаль) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
Помогите написать программу в паскаль АBC задание: Напишите программу которая в последовательности натуральных чисел определяет чётное минимальное число. При этом кол-во введённых чисел неизвестно. Но не превышает 1000.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1. Приветствие участникам олимпиады от лунных человечков записано с помощью всех символов лунного алфавита: ЮМА_ЮМ. Сколько информации оно несет? 2. Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов.
Ответы (2)