Задать вопрос
25 декабря, 20:06

1. Массив из 15 элементов задан случайными целыми числами в диапазоне от - 10 до 10. Подсчитать среднее арифметическое всех чётных элементов массива, стоящих на нечётных местах.

+2
Ответы (1)
  1. 25 декабря, 22:55
    0
    Var a: array [1 ... 15] of integer;

    i, sum, k: integer; sa: real;

    Begin

    For i:=1 to 15 do

    a[i]:=Random (21) - 10;

    writeln ('Исходный массив:') ;

    For i:=1 to 15 do

    write (a[i], ' ') ;

    writeln;

    sum:=0; {первоначально сумме присваивается значение 0}

    k:=0; {первоначально счетчику присваивается значение 0}

    For i:=1 to 15 do

    if (a[i] mod 2=0) and (i mod 2=1) then

    begin

    sum:=sum+a[i]; {подсчет суммы}

    k:=k+1; {подсчет количества элементов}

    end;

    sa:=sum/k; {вычисление среднего арифметического}

    writeln ('Среднее арифметическое четных элементов массива, стоящих на нечетных местах = ', sa:4:2) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Массив из 15 элементов задан случайными целыми числами в диапазоне от - 10 до 10. Подсчитать среднее арифметическое всех чётных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1 задача: Массив Z (20) заполнить целыми случайными числами в диапазоне от - 20 до 20. Вычислить CP - среднее арифметическое положительных элементов и CN - среднее арифметическое отрицательных элементов массива Z.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Напишите программу, которая заполняет массив из N элементов случайными целыми числами в диапазоне [ A, B ] и определяет среднее арифметическое элементов этого массива.
Ответы (1)