Задать вопрос
8 января, 19:48

Задание по ИКТ! Составить программу с пояснениями! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их сумму. В паскале а если еще можно то блок схему)

+3
Ответы (1)
  1. 8 января, 21:49
    0
    Program mas;

    const n=4; / / число элементов

    var a: array [1 ... n] of integer; / / массив

    i, sum: integer; / / переменные

    begin / / начало

    sum:=0; / / сумма=0

    for i:=1 to n do readln (a[i]) ; / / вводим массив

    for i:=1 to n do / / цикл

    if (a[i] mod 2 0) then / / условие нечетности

    begin

    writeln (a[i]) ; / / выводим нечетные

    sum:=sum+a[i]; / / считаем сумму

    end;

    writeln (sum) ; / / выводим сумму

    end. / / конец
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание по ИКТ! Составить программу с пояснениями! Дан целочисленный массив с числом элементов N и вывести из него нечетные элементы и их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
Дан целочисленный массив из 35 элементов элементы массива могут принимать целые значения от 0 до 1000. составьте программу позволяющию найти и вывести сумму элементов в массив из 35 элементов массива, кратных тринадцати
Ответы (1)