Задать вопрос
23 июля, 11:25

Выяснить, лежит ли на одной прямой точки А (x1, y1), B (x2, y2), C (x3, y3). Координаты точек вводятся пользователем с клавиатуры, результат работы программы выводится на экран

+3
Ответы (1)
  1. 23 июля, 12:48
    0
    Var x1, y1, x2, y2, x3, y3, a, b:real;

    begin

    write ('A: ') ; readln (x1, y1) ;

    write ('B: ') ; readln (x2, y2) ;

    write ('C: ') ; readln (x3, y3) ;

    a: = (y2-y1) / (x2-x1) ;

    b:=y2-a*x2;

    if y3=a*x3+b

    then writeln ('Точки лежат на одной прямой')

    else writeln ('Точки не лежат на одной прямой') ;

    end.

    Пример:

    A: 1 1

    B: 2 3

    C: 3 5

    Точки лежат на одной прямой
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Выяснить, лежит ли на одной прямой точки А (x1, y1), B (x2, y2), C (x3, y3). Координаты точек вводятся пользователем с клавиатуры, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Даны 2 действительных числа. Заменить первое число нулем, если оно меньше или равно второго, и оставить числа без изменения числа в противном случае. Числа вводятся пользователем с клавиатуры. Результат работы программы выводится на экран
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Определить максимальное значение среди чисел x и y, минимальное значение среди чисел a и b. Числа x и y, a и b вводятся с клавиатуры. Результат работы программы выводится на экран
Ответы (1)
Помогите сделать в паскале! Запросить с клавиатуры координаты точки (X, Y) и горизонтального отрезка прямой (Xn, Xk, Yn) и определить, лежит точка на отрезке прямой или нет. Сообщение об этом вывести на экран. Подсказка.
Ответы (1)