Задать вопрос
19 июля, 07:56

Определить максимальное значение среди чисел x и y, минимальное значение среди чисел a и b. Числа x и y, a и b вводятся с клавиатуры. Результат работы программы выводится на экран

+1
Ответы (1)
  1. 19 июля, 10:06
    0
    Var

    a, b, x, y, max, min: real;

    begin

    write ('Введите x и y: ') ;

    read (x, y) ;

    write ('Введите a и b: ') ;

    read (a, b) ;

    if a < b then

    begin

    min : = a;

    end

    else min : = b;

    if x > y then

    begin

    max : = x;

    end

    else max : = y;

    writeln ('max для x и y: ', max) ;

    writeln ('min для a и b: ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить максимальное значение среди чисел x и y, минимальное значение среди чисел a и b. Числа x и y, a и b вводятся с клавиатуры. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 2 действительных числа. Заменить первое число нулем, если оно меньше или равно второго, и оставить числа без изменения числа в противном случае. Числа вводятся пользователем с клавиатуры. Результат работы программы выводится на экран
Ответы (1)
Выяснить, лежит ли на одной прямой точки А (x1, y1), B (x2, y2), C (x3, y3). Координаты точек вводятся пользователем с клавиатуры, результат работы программы выводится на экран
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)