Задать вопрос
12 мая, 18:15

Напишите программу вычисления итоговой суммы покупки с учетом скидки. Скидка в размере 7 % начисляется, если сумма покупки более 5000 руб. Сумма покупки вводится пользователем с клавиатуры. Результат работы программы вводится на экран

+1
Ответы (1)
  1. 12 мая, 20:54
    0
    Если я тебя правильно понял:

    var

    a, f: real;

    begin

    readln (a) ;

    if a > = 5000 then

    begin

    f : = a - (0.07 * a) ;

    writeln (f) ;

    end

    else

    if a < 5000 then

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу вычисления итоговой суммы покупки с учетом скидки. Скидка в размере 7 % начисляется, если сумма покупки более 5000 руб. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка в 10% предоставляется, если сумма покупки больше 1000 рублей.
Ответы (1)
Составить программу вычисления стоимости покупки с учётом скидки. Скидка 3% предоставляется в том случае, если сумма покупки больше 500 рублей, 5% - если сумма больше 1000 рублей.
Ответы (1)
Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. (Pascal)
Ответы (1)