Задать вопрос
3 июня, 04:50

Составить на Pascal программу с использованием процедуры и функции:

"Даны действительные числа a1, ..., an, b1, ..., bn. В последовательности a1, ..., an, и в последовательности b1, ..., bn все элементы, следующие за элементом с наибольшим значением (за первым по порядку, если их несколько), заменить на 0,5."

+4
Ответы (1)
  1. 3 июня, 07:26
    0
    Var ar1:array of real; ar2:array of real;

    n, i, maxi1, maxi2, seed:integer;

    max1, max2:real;

    function gener (var ar:array of real; i:integer; var seed:integer) : real;

    begin;

    randomize (seed) ;

    {В этой задаче я впервые столкнулся с неслучайным random (). Чтобы она генерировала новый ряд чисел, измените значение seed в начале основной программы}

    seed:=random (-10,10) ;

    ar[i]:=random (-10,10) ;

    gener:=ar[i];

    end;

    procedure maxS (ar:array of real; var maxi, n:integer; var max:real) ;

    var i:integer;

    begin;

    max:=-2147483648;

    for i:=1 to n do if max
    begin;

    max:=ar[i];

    maxi:=i;

    end;

    for i:=maxi+1 to n do

    ar[i]:=0.5;

    end;

    begin;

    randomize;

    readln (n) ;

    setlength (ar1, n+1) ;

    setlength (ar2, n+1) ;

    writeln ('Array A:') ;

    for i:=1 to n do

    write (gener (ar1, i, seed) : 4) ;

    seed:=random (-10,10) ;

    writeln;

    writeln ('Array B:') ;

    for i:=1 to n do

    write (gener (ar2, i, seed) : 4) ;

    maxS (ar1, maxi1, n, max1) ;

    maxS (ar2, maxi2, n, max2) ;

    writeln;

    writeln ('Final array A:') ;

    for i:=1 to n do

    write (ar1[i]:4) ;

    writeln;

    writeln ('Final array B:') ;

    for i:=1 to n do

    write (ar2[i]:4) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить на Pascal программу с использованием процедуры и функции: "Даны действительные числа a1, ..., an, b1, ..., bn. В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
В матрице A найти строку с наименьшим элементом и упорядочить элементы этой строки по возрастанию. Результат записать в матрицу Б. Элементы матрицы А вычисляется по формуле a_{ij} = sinj (1-sini), где i, j=1,2 ... 10. Pascal. Через процедуры
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Даны последовательности А, В, С. В каждой из них 20 целых чисел. В той последовательности, где больше всего 0 (считая что такая последовательность одна), все 0 заменить наибольшим значением данной последовательности (теория алгоритмов)
Ответы (1)