Задать вопрос
27 мая, 19:23

Входные данные некоторый программы записаны в текстовый файл. В каждой строке файла содержится два целых и три вещественных числа, разделенные пробелами. Напишите программу, которая выводит на экран сумму целых и сумму вещественных чисел из каждой строки.

+1
Ответы (1)
  1. 27 мая, 19:30
    0
    Var

    f:Text;

    i, j:integer;

    a, b, c:real;

    begin

    Assign (f,'MyFile. txt') ;

    Reset (f) ;

    while not eof (f) do begin

    Read (f, i, j) ; Readln (f, a, b, c) ;

    Writeln (i+j,' ', a+b+c)

    end;

    Close (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Входные данные некоторый программы записаны в текстовый файл. В каждой строке файла содержится два целых и три вещественных числа, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)