Задать вопрос
5 сентября, 18:56

Дан одномерный массив A1, A2 ..., An. Все элементы с нечетными номерами разделить нацело на первый элемент

+2
Ответы (1)
  1. 5 сентября, 19:49
    0
    Vara:array[1 ... 512] of integer;

    i, n:integer;

    begin

    writeln ('vvedite rezmer massiva') ;

    readln (n) ;

    for i:=1 to n do

    begin

    write ('a[', i,']=') ;

    readln (a[i]) ;

    if (i1) and (i mod 20) then a[i]:=a[i] div a[1];

    end;

    write ('rezultat ') ;

    for i:=1 to n do

    write ('a[', i,']=', a[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерный массив A1, A2 ..., An. Все элементы с нечетными номерами разделить нацело на первый элемент ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
Нужна помощь! 1. дан массив состоящий из 5 случайных целых чисел от - 1 до 10. Все его элементы уменьшить на число 20. 2. дан массив состоящий из 8 вещественных чисел. все элементы с четными номерами уменьшить на 1, с нечетными-увеличить на 1.
Ответы (1)
1). Дан массив из n чисел (n четное). Написать программу миняющую местами элементы с четными и нечетными номерами 2). Дан массив из n чисел.
Ответы (1)
Что такое одномерный массив в информатике? Для чего используется одномерный массив? Как описывается одномерный массив?
Ответы (1)