Задать вопрос
29 апреля, 19:03

Ввести целочисленный массив состоящий из 17 элементтв. Найти сумму и количество положительных элементов. Паскаль АБС

+5
Ответы (1)
  1. 29 апреля, 22:07
    0
    Const

    N=17;

    var

    i, sum, col:integer;

    a:array[1 ... N] of integer;

    begin

    for i:=1 to N do readln (a[i]) ;

    for i:=1 to N do begin

    if (a[i]>0) then inc (col) ;

    if (a[i]>0) then sum:=sum+a[i];

    end;

    writeln (sum,' ', col) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ввести целочисленный массив состоящий из 17 элементтв. Найти сумму и количество положительных элементов. Паскаль АБС ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Имеется целочисленный массив состоящий из N элементов (N - чётное) а) Найти сумму первых N/2 элементов. б) Найти сумму элементов стоящих на чётных позициях. в) Найти произведение элементов стоящих на нечётных позициях.
Ответы (1)