Задать вопрос
8 ноября, 08:28

1. Составить программу максимума из двух чисел.

2. Составить программу вычисления наибольшего из четырех чисел с использованием процедуры определения наибольшего из двух чисел.

+4
Ответы (1)
  1. 8 ноября, 08:45
    0
    1) program p1;

    var a, b:integer;

    begin

    writeln ('Введите 1-е число: ') ; read (a) ;

    writeln ('Введите 2-е число: ') ; read (b) ;

    if (a>=b) then writeln ('максимальное число: ', a) else writeln ('максимальное число: ', b) ;

    end.

    2)

    program p1;

    procedure MaxNumber (a, b: integer; var max: integer) ;

    begin

    if a>=b then max:=a else max:=b;

    end;

    var a, b, c, d, m:integer;

    begin

    writeln ('Введите 1-е число: ') ; read (a) ;

    writeln ('Введите 2-е число: ') ; read (b) ;

    writeln ('Введите 3-е число: ') ; read (c) ;

    writeln ('Введите 4-е число: ') ; read (d) ;

    MaxNumber (a, b, m) ;

    MaxNumber (m, c, m) ;

    MaxNumber (m, d, m) ;

    writeln ('максимальное число: ', m) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составить программу максимума из двух чисел. 2. Составить программу вычисления наибольшего из четырех чисел с использованием процедуры ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Написать программу с использованием процедуры или функции. Объявлен массив целых чисел. m размером 5 х10. Заполнить массив числами из промежутка [-20,20]. Каждый элемент массива заменить его кубом. Исходный и измененный массив вывести на экран.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)