Задать вопрос
26 августа, 21:56

Ежедневно мама дает сыну на 1 рубль больше суммы предыдущего дня (начиная с 1 руб). Сколько мальчик накопит за год?

составить в паскале программу вычисление

(циклом)

+3
Ответы (1)
  1. 27 августа, 01:26
    0
    Программа.

    var q, s:integer;

    begin

    s:=1;

    for q:=1 to 365 do

    s:=s+q;

    Writeln (s) ;

    end.

    Описание программы.

    var q, s:integer; / / Объявление переменных, где q - цикл от 1 до 365, s - сумма результата.

    begin / / Начало выполнение программы.

    s:=1; / / Присваиваем переменной s значение 1, т. к. по условию 1 рубль.

    for q:=1 to 365 do / / Цикл от 1 до 365

    s:=s+q; / / Сумма цикла. То есть - Сумма = Сумма + Цикл с шагом 1. Начальное значение s равно 1, поэтому сумма считывается больше суммы предыдущего дня.

    Writeln (s) ; / / Вывод результата.

    end. / / Конец выполнение программы.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ежедневно мама дает сыну на 1 рубль больше суммы предыдущего дня (начиная с 1 руб). Сколько мальчик накопит за год? составить в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Если выполнения алгоритма заканчивается, когда условие цикла становится истинным, то он называется: 1) циклом с предусловием 2) бесконечность 3) циклом n-раз 4) циклом с постусловием
Нет ответа
Составить программу вычисления суммы всех натуральных чисел меньше 100 и кратных b (от1 до 100). Нужно составить 1 - с циклом с пред условием, 2 - с циклом с пост условием
Ответы (1)
Написать программу в Паскале. Используя операторы цикла и условия, написать программу, которая из введенных N чисел: 1) Находит и выводит на экран все двухзначные числа, кратные 10 (с циклом mod). 2) Найти сумму всех чисел больше 10.
Ответы (1)
Написать программу в Pascal по циклам: Ежедневно ученик делает в диктанте разное кол-во ошибок. За сколько дней кол-во ошибок достигнет числа q? (Написать программу с циклом while)
Ответы (1)
Укажите, что дано и что надо получить: а) вычисление стоимости покупок в магазине б) вычисление суммы сдачи от данных вами продавцу денег в) определение времени показа по телевизору интересующего вас фильма г) вычисление площади треугольника д)
Ответы (1)