Задать вопрос
30 ноября, 06:28

Дан одномерных массив содержащий n элементов и заполненный с клавиатуры. Сформулируйте новый массив из отрицательных элементов исходного массива

+1
Ответы (1)
  1. 30 ноября, 09:39
    0
    Var

    a:array[1 ... 10000000] of real;

    b:array[1 ... 10000000] of real;

    n, i:integer;

    c:real;

    begin

    write ('Размер массива - ') ;

    readln (n) ;

    write ('Заполните массив - ') ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n do

    begin

    b[i]:=a[i] * (-1) ;

    write (b[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан одномерных массив содержащий n элементов и заполненный с клавиатуры. Сформулируйте новый массив из отрицательных элементов исходного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. Дан одномерный массив размерностью 10, заполненный целыми числами, введенными с клавиатуры, и величина N. Отрицательные элементы заменить на N. Измененный массив вывести на экран одной строкой. 2.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)