Задать вопрос
19 июля, 23:03

Для заданной целочисленной матрицы А (N, N) определите, является ли сумма элементов расположенных ниже главной диагонали четным числом

+3
Ответы (1)
  1. 20 июля, 02:29
    0
    Var x, i, j, sum, n:int64; beginread (n) ; for i:=1 to n do begin for j:=1 to n do begin read (x) ; if i>j then begin inc (sum, x) ; end; end; end; if (sum mod 2) = 0 then begin sum:=sum div 2; if (sum mod 2) = 0 then writeln ('YES') else writeln ('NO') ; end else writeln ('NO') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Для заданной целочисленной матрицы А (N, N) определите, является ли сумма элементов расположенных ниже главной диагонали четным числом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)