Задать вопрос
9 марта, 07:32

Найти сумму 4+9 + ... + m^2, лишь из слагаемых, меньших k.

+4
Ответы (2)
  1. 9 марта, 08:29
    0
    uses crt; var m, p, i:integer; begin write ('M = ') ; read (m) ; p:=1; for i:=1 to m do begin p:=p * (2*i+1) ; end; write ('p = ', p) ; end.
  2. 9 марта, 09:49
    0
    Можно решить арифметически:

    program zad;

    var m:integer;

    begin

    read (m) ;

    writeln ((m * (m+1) * (2*m+1)) / 6-1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму 4+9 + ... + m^2, лишь из слагаемых, меньших k. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр, меньших 7, требуется на экран вывести 0
Ответы (2)
Сумма красивых чисел, меньших 30, равна 45 (10 + 12 + 23 = 45). Найдите сумму красивых натуральных чисел, меньших 10000
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Назовём красивыми числа, в записи которых есть минимум две одинаковые цифры (например: 44, 505, 1101, 2324). Сумма красивых чисел, меньших 100, равна 495 (11 + 22 + 33 + 44 + 55 + 66 + 77 + 88 + 99 = 495).
Ответы (1)
В одномерном массиве, состоящем из n целых элементов, вычислить: 1) Сумму модулей элементов массива, больших числа X 2) Сумму модулей элементов массива, меньших числа X
Ответы (1)