Задать вопрос
21 марта, 09:52

В одномерном массиве, состоящем из n целых элементов, вычислить:

1) Сумму модулей элементов массива, больших числа X

2) Сумму модулей элементов массива, меньших числа X

+5
Ответы (1)
  1. 21 марта, 10:23
    0
    Const n=20;

    var i:integer;

    sl, sg:longint;

    x:real;

    a:array[1 ... n] of integer;

    begin

    Randomize;

    for i:=1 to n do a[i]:=random (1000) - 500; / / Случайные числа от - 500 до 500

    sl:=0; sg:=0;

    writeln ('Введите число Х') ;

    readln (x) ;

    for i:=1 to n do

    if a[i]
    writeln ('Сумма меньших: ', sl,' Сумма больших: ', sg)

    end.

    Пример решения:

    Введите число Х

    25

    Сумма меньших: 1731 Сумма больших: 2407
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В одномерном массиве, состоящем из n целых элементов, вычислить: 1) Сумму модулей элементов массива, больших числа X 2) Сумму модулей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В одномерном массиве, состоящем из n целых элементов, вычислить: 1.) минимальный по модулю элемент массива; 2.) сумму модулей элементов массива, расположенных после первого элемента, равного нулю.
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)