Задать вопрос
4 апреля, 04:42

Назовём красивыми числа, в записи которых есть минимум две одинаковые цифры (например: 44, 505, 1101, 2324).

Сумма красивых чисел, меньших 100, равна 495 (11 + 22 + 33 + 44 + 55 + 66 + 77 + 88 + 99 = 495).

Найдите сумму красивых натуральных чисел, меньших 10000.

+3
Ответы (1)
  1. 4 апреля, 05:15
    0
    Var a, c, s:integer;

    m:set of 0 ... 9;

    b:boolean;

    begin

    s:=0;

    for a:=10 to 9999 do

    begin

    m:=[];

    c:=a;

    b:=false;

    while c0 do

    begin

    if (c mod 10) in m then b:=true;

    m:=m+[c mod 10];

    c:=c div 10;

    end;

    if b then s:=s+a;

    end;

    writeln ('s = ', s) ;

    end.

    Результат:

    s = 24717105
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Назовём красивыми числа, в записи которых есть минимум две одинаковые цифры (например: 44, 505, 1101, 2324). Сумма красивых чисел, меньших ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сумма красивых чисел, меньших 30, равна 45 (10 + 12 + 23 = 45). Найдите сумму красивых натуральных чисел, меньших 10000
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)