Задать вопрос
11 июля, 12:36

Помогите написать программу в Паскаль.

Дан произвольный текст. Преобразовать его по следующим правилам: все буквы "о" заменяются на "оа", все пробелы заменяются символом "_", а запятые удаляются.

+2
Ответы (1)
  1. 11 июля, 13:26
    0
    S - переменная текста

    i - счетчик

    readln (s) ;

    for i: = 1 to length (s) do

    begin

    if (s[i]='о') then

    s[i]:='оа';

    if (s[i]=' ') then

    (s[i]='_')

    if (s[i]=',') then

    s[i]:='';

    writeln (s) ;

    end.

    Вроде как-то так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскаль. Дан произвольный текст. Преобразовать его по следующим правилам: все буквы "о" заменяются на "оа", ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
Написать программу на Паскале АВС. Дана строка, в которой есть точки, запятые, пробелы, тире, слова. В общем, много-много всего. Нужно преобразовать строку по правилам Ворда. То есть 1. между словами один пробел 2.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)