Задать вопрос
23 июля, 11:24

Оставить программу Pascal вывода на экран n чисел Фибоначчи

+5
Ответы (1)
  1. 23 июля, 11:31
    0
    Числа Фибоначчи - это элементы числовой последовательности, в которой каждое последующее число равно сумме двух предыдущих.

    var a, b, c, i, n: integer;

    begin

    write ('Введи n = ') ;

    readln (n) ;

    a : = 0;

    write (a,' ') ;

    b : = 1;

    write (b,' ') ;

    for i:=3 to n do begin

    write (a+b,' ') ;

    c : = b;

    b : = a + b;

    a : = c

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Оставить программу Pascal вывода на экран n чисел Фибоначчи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Дан двухмерный массив m*n случайных целых чисел, которые должны генерироваться в диапазоне [-5, 7], где 1 ≤ т ≤ 9, 1 ≤ n ≤ 10.
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Cоставить алгоритм и программу для: 1) Заполнения лвумерного массива (6x4) произвольными значениями и вывода его на экран! 2) Подсчета произведения элементов по строкам и вывода на экран номеров строк и соответствующих произведений элементов!
Ответы (1)