Задать вопрос
6 ноября, 04:30

Помогите сделать программу в паскали очень прошу. Найти, сколько положительных элементов содержит данная матрица в каждом столбце

+1
Ответы (1)
  1. 6 ноября, 07:18
    0
    Const

    maxElements = 1000;

    var arr : array[1 ... maxElements, 1 ... maxElements] of integer;

    counterArray : array[1 ... maxElements] of integer;

    i, j, n, m, countOfPositive: integer;

    begin

    write ('Введите количество строк: ') ;

    readln (n) ;

    write ('Введите количество столбцов: ') ;

    readln (m) ; writeln ('Введите элементы массивы') ;

    for i:=1 to n do

    for j:=1 to m do

    read (arr[i, j]) ;

    countOfPositive : = 0;

    for j:=1 to m do

    begin

    for i:=1 to n do

    if arr[i, j] > 0 then Inc (countOfPositive) ;

    counterArray[j] : = countOfPositive;

    countOfPositive : = 0;

    end;

    writeln ('Количество положительных элементов в каждом столбце') ;

    for j:=1 to m do

    write (counterArray[j], ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите сделать программу в паскали очень прошу. Найти, сколько положительных элементов содержит данная матрица в каждом столбце ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите с кодом по паскалю.→Нужно чтобы ответ который показывается было написано первый столбец столько положительных чисел а если нет положительных чисел в столбце то писало нет положительных чисел в этом столбце←Столбцы пронумеровать Изначально
Ответы (1)
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
Помогите решить задачку (Паскаль) Дана матрица B (4,4) 1) Найти произведение положительных элементов среди элеметов рассположенных выше побочной диагонали матрицы B. 2) Найти минимальный элемент во втором столбце матрицы B.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите написать программу на VisualBasic! Дана матрица Y (5,5) (элементы матрицы выбрать самостоятельно). Вы- числить элементы новой матрицы Z (5,5) по правилу: zij = yij / ki, где ki - количе- ство положительных элементов i-той строки.
Ответы (1)