Задать вопрос
26 января, 17:43

Пользователь вводит трехзначное число, надо вычислить сумму чисел этого числа.

+4
Ответы (1)
  1. 26 января, 18:16
    0
    Var x, a, b, c:integer;

    begin

    write ('Введите число: ') ; read (x) ;

    a:=x div 100;

    b:=x div 10 mod 10;

    c:=x mod 10;

    writeln ('сумма цифр: ', a+b+c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит трехзначное число, надо вычислить сумму чисел этого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Какое событие наступит после того, как: А) ученик встретит учителя Б) пользователь выберет команду меню В) пользователь выберет объект правой кнопкой мыши Г) пользователь включит компьютер Д) пользователь перетянет левый нижний угол окна
Ответы (1)
Пользователь клавиатуры вводит в минуту 60 знаков. Какое количество текстовой информации вводит этот пользователь за 5 минут в кодировке Unicode?
Ответы (1)