Задать вопрос
8 июня, 22:31

Дан массив А (m), m < = 15. Заменить нулем каждый отрицательный элемент массива и вычислить сумму S и количество К оставшихся положительных элементов. Вывести на печать исходный и преобразованный массивы, а так же величины S, K

+3
Ответы (1)
  1. 8 июня, 23:44
    0
    Const n=15;

    var a:array[1 ... n] of integer;

    i, s, k:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (21) - 10;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0; k:=0;

    for i:=1 to n do

    if a[i]<0 then a[i]:=0

    else if a[i]>0 then begin s:=s+a[i]; k:=k+1; end;

    for i:=1 to n do write (a[i]:4) ;

    writeln;

    writeln ('s=', s,' k=', k) ;

    end.

    Пример:

    -8 - 3 10 0 3 1 - 10 8 4 - 3 9 0 - 10 - 2 1

    0 0 10 0 3 1 0 8 4 0 9 0 0 0 1

    s=36 k=7
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив А (m), m < = 15. Заменить нулем каждый отрицательный элемент массива и вычислить сумму S и количество К оставшихся положительных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)