Задать вопрос
14 июля, 13:17

Составить программу, которая формирует массив из 11 случайных целых промежутка [0,15] и выводит на экран сумму и среднее арифметическое элементов массива

+3
Ответы (1)
  1. 14 июля, 16:22
    0
    Const n=11;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (16) ;

    write (a[i],' ') ;

    end;

    writeln;

    s:=0;

    for i:=1 to n do s:=s+a[i];

    writeln ('s=', s,' sr=', s/n:5:2) ;

    end.

    Пример работы:

    6 12 7 9 3 15 10 10 6 2 8

    s=88 sr = 8.00
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая формирует массив из 11 случайных целых промежутка [0,15] и выводит на экран сумму и среднее арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными индексами. выведите на экран исходный массив и полученное среднее арифметическое. 2.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)