Задать вопрос
6 августа, 06:08

Найти все трехзначные числа, сумма которых равна их произведению Паскаль

+1
Ответы (2)
  1. 6 августа, 06:24
    0
    var

    a, b, i, n:integer;

    begin

    for i:=100 to 999 do

    if ((i mod 10) + (i div 10) + (i div 100)) = ((i mod 10) * (i div 10) * (i div 100)) then

    begin

    write (i,' ') ;

    a:=a+1;

    end;

    if a=0 then

    writeln ('Нет таких чисел') ;

    end.

    {Программа работает, но чисел таких нет}
  2. 6 августа, 08:39
    0
    Аналогично

    begin

    for var a : = 100 to 999 do begin

    for var b : = 100 to 999 do begin

    if a * b = a + b then writeln (a,'-', b) ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все трехзначные числа, сумма которых равна их произведению Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
1) вывести трехзначные числа сумма цифр которых простое число pascal. 2) Дана последовательность 5,9,13,17, ... Составте программу для определения числа слагаемых, сумма которых равна 324.
Ответы (1)
Написать программу в Паскале: 1) Вводятся 10 целых чисел. Подсчитать количество четных среди них 2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).
Ответы (1)