Задать вопрос
13 сентября, 23:57

2."Бесконечное число". Маша называет число бесконечным, если в нем встречается цифра 8 или любая другая цифра встречается больше одного раза. Является ли введенное число бесконечным?

+5
Ответы (1)
  1. 14 сентября, 00:36
    0
    Program Number;

    var x: integer; { введенное число } n: byte : = 0; { количество цифр в числе } i, j: byte; { счетчики } xi: array[1 ... 5] of integer; {массив цифр, из которых состоит число}

    begin { Ввод исходного числа } readln (x) ; writeln; x : = abs (x) ; / / рассматриваем модуль числа { Разбиение числа на цифры } while (x > 0) do begin n : = n + 1; / / увеличиваем количество цифр xi[n] : = x mod 10; / / вычисляем цифру (остаток от деления на 10) if xi[n] = 8 then / / если встретилась 8, begin writeln ('да') ; / / то число "бесконечное" readln; exit; / / выход из программы end; x : = x div 10; / / изменяем число (целое от деления на 10) end; { Поиск цифр, встречающихся больше одного раза} for i : = 1 to n - 1 do for j : = i + 1 to n do if xi[i] = xi[j] then / / если числа begin writeln ('да') ; / / то число "бесконечное" readln; exit; / / выход из программы end; { Число не явлется "бесконечным" } writeln ('нет') ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «2."Бесконечное число". Маша называет число бесконечным, если в нем встречается цифра 8 или любая другая цифра встречается больше одного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте программу, проверяющую, что введенное число является четным или нечетным 2. Составьте программу, проверяющую, что введенное число делится без остатка на 3
Ответы (1)
Напишите программу вывода на экран фразы "Число положительное", если введенное число положительное, и "Число отрицательное", если введенное число отрицательное.
Ответы (1)
Разработать программу, реализующую следующий функционал: 1.1. Программа запрашивает у пользователя число от 1 до 10 (n). 1.2. Программа проверяет введенное число на правильность: больше либо равно 1 и меньше либо равно 10. 1.3.
Ответы (1)
Удвоить трехзначное число, введенное с клавиатуры, если оно содержит в своей записи хотя бы одну единицу, и возвести в квадрат в другом случае. Если введенное число не трехзначное, вывести сообщение об ошибке.
Ответы (1)
Если целое число М, введенное с клавиатуры, делится на целое число Н, введенное с клавиатуры, с остатком равным 2, то вывести на экран целую часть от деления М на Н, в противном случае - сообщение "при делении ... на ... остаток не равен 2"
Ответы (1)