Задать вопрос
15 июня, 15:25

Найти стоимость заданного количества ткани. Цена и количество вводятся с клавиатуры. (Составьте программу Паскаль)

Язык программы Паскаль.

+5
Ответы (1)
  1. 15 июня, 17:14
    0
    Var

    a, b, c: integer;

    x, y, z:string;

    begin

    x:='рубль';

    y:='рубля';

    z:='рублей';

    writeln ('Сколько стоит метр ткани? (в рублях) ') ;

    readln (a) ; writeln ('Сколько вы хотите купить ткани? (в метрах квадратных) ') ; readln (b) ;

    c:=a*b;

    if c=1 then

    begin

    writeln ('Это будет стоить',' ', c,' ', x) ;

    end;

    if (2<=c) and (c<=4) then

    begin

    writeln ('Это будет стоить',' ', c,' ', y) ;

    end;

    if (5 < = c) and (c < = 1000000) then

    begin

    writeln ('Это будет стоить',' ', c,' ', z) ;

    end;

    end.

    В зависимости от результата программа будет выводить разное окончание.

    1 рубль;

    3 рубля;

    100 рублей.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти стоимость заданного количества ткани. Цена и количество вводятся с клавиатуры. (Составьте программу Паскаль) Язык программы Паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)