Задать вопрос
15 сентября, 21:49

На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. Сколько учеников получило зачёт? Вычислите среднее количество правильно решённых задач учащимися, получившими зачёт. Гарантируется, что хотя бы один ученик сдал зачёт.

Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых задач.

+5
Ответы (1)
  1. 15 сентября, 23:55
    0
    Решение:

    var i, n, b, c:integer;

    begin

    read (n) ;

    for i:=1 to n do

    begin

    read (b) ;

    if b>=8 then c:=c+1;

    end;

    writeln ('Количесво учеников, сдавших экзамен: ', c)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу решения задачи: На зачётной работе по физике ученикам 9 класса было предложено 12 задач. Зачёт можно получить, если правильно решить не менее 8 задач.
Ответы (1)
Определить, кто из четырех студентов сдал экзамен, если известно: 1) Если первый сдал, то и второй сдал; 2) Если второй сдал, то третий сдал или первый не сдал; 3) Если четвертый не сдал, то первый сдал, а третий не сдал;
Ответы (1)
Определите максимальное число учеников, сдавших экзамен при условии, что: 1. если первый сдал, то и второй сдал; 2. если второй сдал, то третий сдал или первый не сдал; 3. если четвертый не сдал, то первый сдал, а третий не сдал; 4.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)