Задать вопрос
21 февраля, 22:22

Дан массив а[1 ... 5] сколько элементов, равных 0, содержит массив? Вывести номера этих элементов, напишите задачку прошу помогите)

+2
Ответы (1)
  1. 21 февраля, 22:32
    0
    Program z1; Var a: array [1 ... 100] of integer; b: array [1 ... 100] of integer; i, j, n, s, m:integer; Begin write ('Введите рамер массива - ') ; readln (n) ; for i:=1 to n do begin a[i]:=random (2) - 0; write (a[i],' ') ; end; s:=0; j:=1; writeln; for i:=1 to n do if (a[i] = 0) then begin s:=s+1; b[j]:=i; j:=j+1; end; m:=j-1; writeln ('Кол-во элементов равнных 0 - ', s) ; write ('Номера этих элементов - ') ; for j:=1 to m do begin write (b[j],' ') ; end; End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив а[1 ... 5] сколько элементов, равных 0, содержит массив? Вывести номера этих элементов, напишите задачку прошу помогите) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)